问题描述

 访问Linux系统的云虚拟主机的PHP站点时,提示以下报错。

 Fatal error: Incompatible file format: The encoded file has format major ID 1, whereas the Loader expects

 问题原因

 云虚拟主机在PHP5.2版本使用的加密组件为Zend Optimizer,但是在5.3版本之后Zend Guard Loader代替了Zend Optimizer加密组件。如果程序中需要使用Zend Optimizer加密组件,在PHP5.3版本下就会出现报错。

 解决方案

 阿里云提醒您:

 如果您对实例或数据有修改、变更等风险操作,务必注意实例的容灾、容错能力,确保数据安全。

 如果您对实例(包括但不限于ECS、RDS)等进行配置与数据修改,建议提前创建快照或开启RDS日志备份等功能。

 如果您在阿里云平台授权或者提交过登录账号、密码等安全信息,建议您及时修改。

 登录主机管理控制台,依次选择高级环境设置>PHP版本设置,选择PHP5.2版本,单击保存设置即可。

分享
继续阅读相关文章

发表评论 快来秀出你的观点

评论区暂时关闭,请谅解!
评论 点赞 收藏